The BMW Project: Drive Train Malfunctions

So lately I have been getting drivetrain malfunctions and its tied to the BM3 flash. I was able to reproduce it by really getting into the throttle in sport mode and sport shift. I had this happen before the flash but it was not reproducible and happened rarely. I backed everything out the engine tune and that went fine. I then tried to back out the Transmission tune and got this:

IMG 0414

When I got into the throttle the drive train malfunction didn’t happen even if I was hard on her. When the transmission is back to stock it doesn’t shift the same when I had it upgraded. I reached out to protuning freaks for assistance and currently they are looking into it.

I also tried resetting adaptations per a BM3 user suggestion on the BM3 facebook group but it didn’t help:

I since then have tried to go back to the BM3 tune and like before engine went with no issues, When I tried to upgrade the transmission I now get this:

I tried doing as it suggested and the “Full flash, unlock (diag only)” went fine but this is for the engine. I get no errors. Then when doing the transmission upgrade I still egt the same error above but this time when I look at diag errors and DME codes I get this:

 

Low charging pressure error

Its interesting according to: https://static.nhtsa.gov/odi/tsbs/2013/SB-10041407-5981.pdf

Its a low pressure charge issue. I do have a Revolution Werks charge pipe but I don’t get that when its stock. I know with the tune boost is higher but will wait and see if it happens again.

Too be continued…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s